Jump to content


Click the link below to see the new game I'm developing!


Photo
- - - - -

Setting SQL_DBNAME under PROIV v9

SQL_DBNAME V9 V8

7 replies to this topic

#1 Marlon

Marlon

    Member

  • Members
  • PipPip
  • 37 posts
  • Gender:Male

Posted 03 September 2020 - 05:28 PM

We have this in our v8 .ini file for connnectiong to an SQL Server system: [ENVIRONMENT] ... SQL_DBNAME=SVR03_DS [Database - SQLDEFAULT] PRODB_CHARSET=7 FILETYPE=SQLSERVE ... We ae trying to connect to SQL Server with v9. We can see where to set PRODB_CHARSET and FILETYPE in the Dashboard: Database section Logical Databases SQLDEFAULT Database Type = SQLSERVE Collation = 7 The problem we have is in defining SQL_DBNAME. The v9 name help https://support.proi...DBNAME&rhsyns= seems to indicate you can define another logical database - it equates proiv.virtualMachine.database.logical[n].name with SQL_DBNAME and sure enough, if we add another logical database, giving SVR03_DS as the name, when we undeploy and redeploy the Profile there is a second set of values in the relevant virtualmachine\config\...properties file but there doesn't appear to be any way to tell PROIV to use that logical database instead of the SQLDEFAULT one and anyway I'm not convinced the help is correct with this. I've also, because SQL_DBNAME is in the [ENVIRONMENT] section of the v8 .ini, defined an environment variable SQL_DBNAME with value SVR03_DS but that doesn't work either. Any suggestions gratefully received. Any solutions evern more gratefully received.

This is your captain speaking. We may experience some slight turbulance and then...explode.


#2 Marlon

Marlon

    Member

  • Members
  • PipPip
  • 37 posts
  • Gender:Male

Posted 03 September 2020 - 05:30 PM

The link to the help didn't work.  It's help topic ID 900009.


This is your captain speaking. We may experience some slight turbulance and then...explode.


#3 Wim Soutendijk

Wim Soutendijk

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 216 posts
  • Gender:Male
  • Location:Netherlands

Posted 07 September 2020 - 07:08 AM

you can set the dbname for sqldefault in the connection string in the format sqlusername/sqlpassword/dbname



#4 Neil Hunter

Neil Hunter

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 420 posts
  • Gender:Male
  • Location:Johannesburg, South Africa

Posted 07 September 2020 - 02:41 PM

Check your Default Virtual Machine Profile. There are also settings there for your default DB

 

Has caught me out a few times 



#5 Marlon

Marlon

    Member

  • Members
  • PipPip
  • 37 posts
  • Gender:Male

Posted 07 September 2020 - 06:07 PM

you can set the dbname for sqldefault in the connection string in the format sqlusername/sqlpassword/dbname


Hi Wim,
Thanks. At the moment, our SQL Server connection string in the Dashboard is
Username/Password@<server>/<installation name>
Would we put the DBName before the @?

This is your captain speaking. We may experience some slight turbulance and then...explode.


#6 Marlon

Marlon

    Member

  • Members
  • PipPip
  • 37 posts
  • Gender:Male

Posted 07 September 2020 - 06:10 PM

Check your Default Virtual Machine Profile. There are also settings there for your default DB
 
Has caught me out a few times 


Hi Neil,
Thanks. Could you put up a screenshot showing that, or email it to Marlon.seton@swallowtech.com if its not possible to put a screenshot on here, please?

This is your captain speaking. We may experience some slight turbulance and then...explode.


#7 Wim Soutendijk

Wim Soutendijk

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 216 posts
  • Gender:Male
  • Location:Netherlands

Posted 08 September 2020 - 07:04 AM

 

you can set the dbname for sqldefault in the connection string in the format sqlusername/sqlpassword/dbname


Hi Wim,
Thanks. At the moment, our SQL Server connection string in the Dashboard is
Username/Password@<server>/<installation name>
Would we put the DBName before the @?

 

Hi Marlon,

 

Perhaps we mean the same as long as dbname or installation name matches the name in the odbc driver. On my configuration @server is not used, and the database connection is ok

 

Wim 



#8 Marlon

Marlon

    Member

  • Members
  • PipPip
  • 37 posts
  • Gender:Male

Posted 17 September 2020 - 02:37 PM

 

 

you can set the dbname for sqldefault in the connection string in the format sqlusername/sqlpassword/dbname


Hi Wim,
Thanks. At the moment, our SQL Server connection string in the Dashboard is
Username/Password@<server>/<installation name>
Would we put the DBName before the @?

 

Hi Marlon,

 

Perhaps we mean the same as long as dbname or installation name matches the name in the odbc driver. On my configuration @server is not used, and the database connection is ok

 

Wim 

 

Hello Wim,

Thanks for your help.  Having "sqlusername/sqlpassword/dbname" in the connection string worked.

 

We have a separate environment variable where we put "sqlusername/sqlpassword@server/registration" which we parse for loading data into tables, hence my somewhat confusing post about having this in SQL_DBNAME.


This is your captain speaking. We may experience some slight turbulance and then...explode.




Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Click the link below to see the new game I'm developing!