Jump to content

- - - - -

ProIV Windows Client via ssh

5 replies to this topic

#1 Vlodik Zmyslony

Vlodik Zmyslony


  • Members
  • PipPip
  • 28 posts
  • Gender:Male

Posted 22 May 2003 - 02:21 AM

Has anyone been able to run the windows cliet via a secure shell (ssh) ?

Please send any details!


#2 Phil Mustoe

Phil Mustoe


  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Bristol, United Kingdom

Posted 22 May 2003 - 08:31 AM

Yes, Managed to get it to work OK, after a fashion.

On Sun Solaris 2.8 needed to download a copy of OpenSSL (v0.9.7b) libraries from http://www.openssl.org/ and compile them up.
Also, we used a wrapper utility called stunnel (v4.0.4) from http://www.stunnel.org/ that uses the openssl libraries - compiled that up.

Added a service into /etc/services file for an unused port, and added a reference within /etc/inetd.conf to execute stunnel when the new port is accessed.
Created a configuration file for stunnel that executes 'in.telnetd'. Need also to create a certificate file for use with stunnel. Not sure whether you can do this, or whether you'd have to obtain one from Pro-IV (which is what we did).
Then, within the Pro-IV Client, needed to change the port number to the new defined port, and enable the 'User Secure Connection' checkbox.
There were a few issues with connection timeouts, but believe that these have been fixed within the latest version of the Pro-IV client.

Whether your site will frown upon having opensource libraries and utilities installed on their machine might be worth checking.

You know when you've got it working because a) the Pro-IV session connects as normal b) You get a little padlock on the bottom of the client, where the function name normally appears.


#3 pdonahue



  • Members
  • Pip
  • 5 posts

Posted 29 May 2003 - 01:29 PM

What version of the PROIV client are you using? I don't see this option in 4.6 for some reason..

#4 Rob Donovan

Rob Donovan


  • Admin
  • 1,647 posts
  • Gender:Male
  • Location:Spain

Posted 29 May 2003 - 02:37 PM


The SSL option is not available in 4.6.

Its a new feature for 5.0+

Rob D.

#5 Tony Waszkiewicz

Tony Waszkiewicz


  • Members
  • PipPipPipPip
  • 174 posts
  • Gender:Male
  • Location:London, United Kingdom

Posted 21 November 2003 - 02:57 PM

Hi All,

I'm trying to get SSL to work on Sun Solaris 2.8 with PROIV 5.5r308 and MFC 503 (505 is very buggy with lots of memory leaks and performance issues). Here's a summary of what I've done so far:

1) downloaded and compiled sslwrap

2) added a service to /etc/services, for example:
telnets 992/tcp # telnet with SSL

3) added an entry to /etc/inetd.conf, for example:
telnets stream tcp nowait smart /usr/sbin/in.telnetd /stl/sslwrap_bin/sslwrap -nocert -port 992

4) added SSL environment variables in /etc/pro4.ini file, e.g.

5) Altered the PROIV connection in the PIV file to 'Use secure connection' with port 992.

On connecting, the 'Connection Status' window appears with a message to say that it is attempting to connect. After a second or so the message disappears and the Windows Client just gets stuck here.

What is going wrong, anyone?


David Blyth

#6 Joseph Bove

Joseph Bove

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 756 posts
  • Gender:Male
  • Location:Ramsey, United States

Posted 09 January 2004 - 04:28 PM

Has anyone setup the ssh client access with Linux?

I thought it would be as simple as setting kEnableSecureConnection=1, changing the port to 22, and the T setting to ssh.

What am I missing?



Reply to this topic


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users