Jump to content


ireddy

Member Since 19 Dec 2006
Offline Last Active Mar 08 2007 05:52 PM
-----

Posts I've Made

In Topic: PRO-IV and remote databases using SQL Server

03 January 2007 - 03:39 PM

:rolleyes: <_< :eek: :D :D

Joseph,

Sorry messed up the reply,

But anyway, it works like a dream now.

I added,

[Database - REMOTE]

PRODB_CHARSET=7

FILETYPE=SQLSERVE

CONNECTION=remote/remote/REMOTE


to the pro4.ini file.

Then setup the ODBC connection and a user on the external database.

Then I changed the alternate against the pro4.ini file to
be %REMOTE%Tablename

and everything works.

But it turned out that one of the guys here, had already done this in another system, he also posted the solution on here a while back, but when I posted my message, he was off until this week.

but thanks anyway

ireddy

:D :D :D :D :D

In Topic: PRO-IV and remote databases using SQL Server

03 January 2007 - 03:24 PM

ireddy,

sorry - I flubbed my first response...

I don't know if this helps or not.

We have accessed remote databases by doing the following:

Add a section like the one below to your application INI file

[DATABASE - REMOTE]
FILETYPE=SQLSERVE
SQL_DBNAME=REMOTE
CONNECTION=REMOTE/REMOTE/REMOTE

Setup the ODBC connection for the remote database

Within your source code, use the alias command to alias the table name as %REMOTE%Tablename

You can then access the table directly.

We have not had any locking problems with this approach... But, I don't know if it fits your business requirements.

hth,

Joseph