Jump to content


- - - - -

Report functions in Proiv 5


18 replies to this topic

#1 Guest_Mark_*

Guest_Mark_*
  • Guests

Posted 08 November 2002 - 06:16 PM

I would like to use external text viewer for viewing and printing report functions from Proiv SLM.
Where and how do I have to define it?

#2 Michael Meneses

Michael Meneses

    Member

  • Members
  • PipPip
  • 47 posts
  • Location:GREENSBORO, United States

Posted 08 November 2002 - 09:56 PM

Include this statement in your proiv.ini

[SETTINGS]
ReportEditor=c:\Windows\Notepad.exe
ReportFileType=TXT

this will tell pro-iv to use NOTEPAD as your default text viewer for your report.

Mike M.

#3 Guest_Mark_*

Guest_Mark_*
  • Guests

Posted 08 November 2002 - 10:09 PM

It's not working. Report is opened with CRT.
Do I have to change some setting inside Proiv?

#4 Guest_Anonymous_*

Guest_Anonymous_*
  • Guests

Posted 11 November 2002 - 02:28 PM

you may have to check your version of proiv, i think it works best for proiv 4.6 to latest if i'm not mistaken.

#5 Rommel Cesista

Rommel Cesista

    Member

  • Members
  • PipPip
  • 22 posts

Posted 12 November 2002 - 10:30 AM

It works with GUI client 4.6 build 208.

#6 Rommel Cesista

Rommel Cesista

    Member

  • Members
  • PipPip
  • 22 posts

Posted 12 November 2002 - 10:33 AM

you have a pro4.ini on your server and a proiv.ini on the client machine that you use.

try editing the proiv.ini on your client machine.

#7 Andy Jones

Andy Jones

    Member

  • Members
  • PipPip
  • 41 posts
  • Gender:Male

Posted 12 November 2002 - 02:07 PM

Mark,

You need to edit the proiv.ini file on the client machine. You'll find this in the main Windows/WinNT folder.

Be sure that you have closed all PROIV clients you have running before altering this file. The client won't pick up the new setting until you reload it.

You will almost certainly have the [Settings] line in the file already, find it and just add the two other lines somewhere below it - but before the start of any other [ ... ] line.

The settings are:

ReportEditor=Notepad.exe
ReportFileType=TXT

You don't need the path for most windows apps - although probably it won't hurt. If you are likely to print very large reports, consider using Wordpad.exe instead as notepad has a 64K file size limit.

HTH

Andy
Nothing is foolproof to a sufficiently talented fool...

Don't learn from your own mistakes - it's safer and more entertaining to learn from the mistakes of others!

Just because you can, it doesn't mean you should!

#8 Rob Donovan

Rob Donovan

    rob@proivrc.com

  • Admin
  • 1,640 posts
  • Gender:Male
  • Location:Spain

Posted 12 November 2002 - 02:26 PM

Hi,

FYI: The 64K limit is now removed in WinXP... Not sure if it was XP or 2000 that they did it in.

But I would think that Wordpad will handle bigger files better, but I'm not sure.

Rob D.

#9 Gary Wilhelm

Gary Wilhelm

    Advanced

  • Members
  • PipPipPip
  • 70 posts
  • Gender:Male
  • Location:Somerset, United States

Posted 12 November 2002 - 08:30 PM

Notepad didn't have a size limit in NT. Notepad handles ASCII better since it does no altering of format so the only thing you can get in a report is a straight ASCII dump.

#10 George Macken

George Macken

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Co. Wicklow, Ireland

Posted 25 June 2003 - 01:51 PM

Hi

I've attempted to get Wordpad working as the default for print to screen

PC - Windows 95
PRO-IV - Ver 4.0 - Rev 5.1.4
GUI Client Ver 4.1

Proiv.ini
[Settings]
MsgBoxCaption=0
TypeAhead=1
IconicMenus=1
FontHeight=22
WorkGroup=0
ReportFileType=DOC
ReportEditor=C:\Program Files\Accessories\Wordpad.exe

NO change occurred - worpad not executing

Then applied same change to proiv.ini on a Version 5 application and wordpad did execute

therefore, I'm assuming this feature does not work on Ver 4.0 running on Windows/NT

If someone has got this feature running on the configuration I mention at top then please let me know ...

migration to ver5.0 is planned for later this yr but could do with this print feature now

thanks

George

#11 Larry Siemer

Larry Siemer

    Member

  • Members
  • PipPip
  • 17 posts
  • Gender:Male
  • Location:Cincinnati, United States

Posted 25 June 2003 - 04:50 PM

Try changing:

ReportFileType=DOC

to

ReportFileType=RTF

#12 Guest_Unix User_*

Guest_Unix User_*
  • Guests

Posted 25 June 2003 - 05:38 PM

Include this statement in your proiv.ini

[SETTINGS]
ReportEditor=c:\Windows\Notepad.exe
ReportFileType=TXT

this will tell pro-iv to use NOTEPAD as your default text viewer for your report.

Mike M.

Think some backslashes might have got swallowed there somewhere..

#13 George Macken

George Macken

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Co. Wicklow, Ireland

Posted 26 June 2003 - 11:04 AM

Hi

thanks for the advice/help above

I've tried above suggestions - wordpad, notepad, DOC, TXT, RTF etc., - path with/without slashes - still the CRT box is executing - not the desired choice

Anybody out there got this feature working on Version 4.0 ???

As mentioned earlier I have it working on another environment under 5.0

Tnks

George

#14 Cleve Haynes

Cleve Haynes

    Expert

  • Members
  • PipPipPipPip
  • 172 posts
  • Gender:Male

Posted 26 June 2003 - 11:14 AM

Hi

I'm pretty sure this feature was added in 4.6 (client 138), so you are wasting your time trying to get it to work with the client from 4.0....

Cleve

#15 George Macken

George Macken

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Co. Wicklow, Ireland

Posted 26 June 2003 - 11:52 AM

tnks

has'nt been a complete waste of time as I at least know how to do for version 5.0/4.6

tnks again to all and especially Rob for providing this forum/resource

George



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users