Jump to content


Photo
- - - - -

ProIV + Postgres = Extremely slow


16 replies to this topic

#16 Richard Bassett

Richard Bassett

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 696 posts
  • Location:Rural France

Posted 06 January 2014 - 02:19 PM

Hi Mike,

 

I haven't used PostgreSQL with ProIV but I have extensive painful experience with other databases  :-"

 

Like you, it made absolutely no sense to me why a savepoint would be being created. I cannot see how that could be normal, indeed I cannot see any reason for it in any regular ProIV processing.  I have never seen that with Oracle or DB2.

 

I was about to suggest this might be an ODBC driver issue as neither Oracle nor DB2 use ODBC with ProIV, however.. I see you have already received an answer in the affirmative elsewhere viz:

 

http://postgresql.10...-td5782434.html

 

+1 to the PostgreSQL community :shifty:

 

Did that in fact fix most of your problem, it would be good to know?


Nothing's as simple as you think

#17 mikelandl

mikelandl

    Expert

  • Members
  • PipPipPipPip
  • 101 posts

Posted 09 January 2014 - 06:08 PM

Hi Mike,

 

I haven't used PostgreSQL with ProIV but I have extensive painful experience with other databases  :-"

 

Like you, it made absolutely no sense to me why a savepoint would be being created. I cannot see how that could be normal, indeed I cannot see any reason for it in any regular ProIV processing.  I have never seen that with Oracle or DB2.

 

I was about to suggest this might be an ODBC driver issue as neither Oracle nor DB2 use ODBC with ProIV, however.. I see you have already received an answer in the affirmative elsewhere viz:

 

http://postgresql.10...-td5782434.html

 

+1 to the PostgreSQL community :shifty:

 

Did that in fact fix most of your problem, it would be good to know?

 

Hi Richard,

 

The same mailing list from the link you came across told me to try adding "UpdatableCursors=0" in odbc.ini. I did that and it made a huge difference.

I've only tested it in a few places so far but one of our reports went from taking 50 seconds to approximately 10 seconds. Looking at the log file created from Postgres, I saw that the number of save points being created as well as the number of queries against the system catalog (pg_class, etc) went down dramatically. I'm just waiting to hear back from ProIV support to get confirmation that this setting will not cause issues elsewhere.





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users