Jump to content


Photo
- - - - -

Form Feed Issue


6 replies to this topic

#1 Tyleulen

Tyleulen

    Advanced

  • Members
  • PipPipPip
  • 59 posts
  • Gender:Male

Posted 16 July 2009 - 07:17 PM

I have a report function that refuses to line up correctly with the pre-printed forms if it goes past the first page. The problem seems to be in the text file that ProIV is generating. On the first page, there is a blank line followed by the page header statics, on the second page there is a ^L followed by the page header statics. The ^L is the page break, and it is in the correct place, but the blank line that appears at the top of the report does not appear after the ^L, so all the pages after the first are shifted up in relation to the form they are printing on.

So, the question is, is there any way to add a line feed in on the second and subsequent pages before the page header, or is there any way to add a blank line to the text file being sent to the spooler after the ^L character?

We are using ProIV 5.5 on a Solaris server (SunOS 5.9) and spooling the printouts to Okidata printers emulating EpsonFX.

#2 DARREN

DARREN

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:Florida,USA

Posted 16 July 2009 - 10:31 PM

I have a report function that refuses to line up correctly with the pre-printed forms if it goes past the first page. The problem seems to be in the text file that ProIV is generating. On the first page, there is a blank line followed by the page header statics, on the second page there is a ^L followed by the page header statics. The ^L is the page break, and it is in the correct place, but the blank line that appears at the top of the report does not appear after the ^L, so all the pages after the first are shifted up in relation to the form they are printing on.

So, the question is, is there any way to add a line feed in on the second and subsequent pages before the page header, or is there any way to add a blank line to the text file being sent to the spooler after the ^L character?

We are using ProIV 5.5 on a Solaris server (SunOS 5.9) and spooling the printouts to Okidata printers emulating EpsonFX.


There is a 'switch' within the spooler setting for a function that allows you to suppress the first line of the report output. I think this may be the answer to your issue (see attached)

Attached Images

  • spoolersettings.jpg

Things should be made as simple as possible, but not simpler

#3 Tyleulen

Tyleulen

    Advanced

  • Members
  • PipPipPip
  • 59 posts
  • Gender:Male

Posted 17 July 2009 - 02:39 PM

Both suppress first line and suppress first form feed are already set. If you uncheck suppress first line, then it adds an automatic function title and page number to the top of the report, which screws up the form alignment, and if you uncheck suppress first form feed it aligns the forms correctly, but wastes a page at the start of every print job.

I have also tried adjusting the page length in the output tab of the report cycles, without any success. The second page always prints differently from the first.

#4 chuckl

chuckl

    Member

  • Members
  • PipPip
  • 26 posts
  • Gender:Male
  • Location:Coppell, Texas

Posted 17 July 2009 - 06:54 PM

Is the first line to be printed on each page set to 'absolute'? Just a thought but if its relative that may be where the extra line is coming from.
chuckl

#5 Lewis Mccabe

Lewis Mccabe

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 455 posts
  • Gender:Male
  • Location:Sarasota, Florida

Posted 18 July 2009 - 01:23 AM

There has been a bug in PROIV reports for years and years where a paging cycle prints an extra line. I can't remember if the extra line is printed on page 1 or pages 2+. I do know that the first page prints differently than all the others. You are going to have to insert some code to skip an extra line feed based on the page#.
Lew

#6 Tyleulen

Tyleulen

    Advanced

  • Members
  • PipPipPip
  • 59 posts
  • Gender:Male

Posted 20 July 2009 - 07:16 PM

There has been a bug in PROIV reports for years and years where a paging cycle prints an extra line. I can't remember if the extra line is printed on page 1 or pages 2+. I do know that the first page prints differently than all the others. You are going to have to insert some code to skip an extra line feed based on the page#.
Lew


Yup. Set a scratch variable at the top of the page header, leave it blank on the first page and set it to: $CRLF = CHAR(13) + CHAR(10) on all the other pages. Now they line up.

Thanks all

#7 Donald Miller

Donald Miller

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 205 posts
  • Gender:Male
  • Location:Cupar, Fife, Scotland
  • Interests:Motorcycling, Running, Cooking

Posted 06 August 2009 - 09:21 PM

There's another solution if you don't actually want the line feed at all - don't use the headers. Even if the page header is empty it still does a line feed. Setting the flag to suppress the header means that the line feed is NOT done.

Put the text/header items into cycles and call them when you want them to be called. Maintain a line count and call the headers, footers (and control breaks) as and when. It may mean a little more work - but it'll give you exactly the results you want since you coded it.


Using the existing page and other headers, footers and control breaks when the complexity of a report function gets beyond some arbitrary point means that figuring out why and how it's not doing what it's supposed to makes the situation unsolvable or the function overly complex and effectively unmaintainable. I'm thinking here of the Invoice Print REPORT function within the Telephone billing system CSC managed in the nineties. Not the update - the report.


This may depend on what release of Pro IV and indeed VIP you are using.
Half of what he said meant something else, and the other half didn't mean anytthing at all



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users