Jump to content


Photo
- - - - -

Report Editor


4 replies to this topic

#1 Cathy

Cathy

    Member

  • Members
  • PipPip
  • 10 posts
  • Location:Michigan

Posted 08 February 2008 - 08:21 PM

Can anyone tell me how to set the Report Editor value on a Windows Server running Proiv 5.5 r5.5.6?

I set the value in PROIV.INI but it seems to just ignore it.

I'm using the server as a stand alone demo system. I have several directories with different proiv applications so I'm using the USER section of the pro4.ini to direct the client to the proper directory. I'm using the INIPATH= to point to the ini file in each directory that holds the specifics.

If I set ReportEditor= in either the PROIV.INI file or the individual ini file that is being pointed to in the PRO4.INI file, it just seems to ignore it and opens the document in the text editor.

Thanks in advance for any help,
Cathy

#2 deepghosh

deepghosh

    Member

  • Members
  • PipPip
  • 37 posts
  • Gender:Male

Posted 10 February 2008 - 07:32 PM

Report Editor Values are now moved into a registry.

There is a movement of all these things into registry from certain version of client.

Please contact PROIV Support to get support on where in the registry it should move and if there is a automatic utility. One good thing about that is all you need to ship is a .reg file and double clicking will update the registry.

#3 Donald Miller

Donald Miller

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 205 posts
  • Gender:Male
  • Location:Cupar, Fife, Scotland
  • Interests:Motorcycling, Running, Cooking

Posted 11 February 2008 - 01:57 PM

Hi Cathy

From 5.6.0.0 the ini files are superseded by the Windows Registry (apparently).

I tried using
ReportEditor=C:\Program Files\Microsoft Office\Office10\Winword
and
ReportFileType=doc
too (on Rev 3.2.5) but both were ignored. When reported to Pro IV they recommended upgrading to a later release.

INIPATH is a flexible way to go but you'll need to manipulate the reports to print to a particular filename or set up the printer definitions so that it is controlled that way instead, probably.

Good luck
Half of what he said meant something else, and the other half didn't mean anytthing at all

#4 deepghosh

deepghosh

    Member

  • Members
  • PipPip
  • 37 posts
  • Gender:Male

Posted 12 February 2008 - 03:19 PM

Do not use

ReportEditor=C:\Program Files\Microsoft Office\Office10\Winword

as your application will not be portable.

Use ReportFileType instead.

and you need to find the right registry key.

#5 deepghosh

deepghosh

    Member

  • Members
  • PipPip
  • 37 posts
  • Gender:Male

Posted 12 February 2008 - 03:21 PM

Ok Got it!

[HKEY_CURRENT_USER\Software\PROIV Technology, Inc.\PROIV Windows Client\Setting]
"ReportFileType"="doc"



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users