Jump to content


Photo
- - - - -

5.5 & Vista


5 replies to this topic

#1 TalentedFool

TalentedFool

    Member

  • Members
  • PipPip
  • 43 posts
  • Gender:Male

Posted 19 January 2007 - 10:37 AM

Is anybody using Vista yet?

If so has anybody had any problems installing the latest Pro-IV 5.5 client? When doing the install it's getting stuck trying to register the ProIVActiveXClient.ocx.

I can stop the install at that point and register the OCX files manually but on entry into Pro-IV I get an error on the entry point into the msvcrt71.dll file - which can't be registered.

The Pro-IV Version I#m using at present it 5.5 v543 mfc 5.6.12

Just wanna check before I go ask Pro-IV..

Cheers
Thanks

Lee

#2 Ian Blew

Ian Blew

    Member

  • Members
  • PipPip
  • 15 posts
  • Gender:Male
  • Location:United Kingdom

Posted 26 January 2007 - 01:29 PM

PROIV won't be supporting Windows Vista until V6.1 (scheduled for release by mid-2007) due to having to change their development environment to a later release.

This is apparently because of major changes in Vista around the MFC libraries.

#3 JamesS

JamesS

    Member

  • Members
  • PipPip
  • 39 posts

Posted 30 January 2007 - 03:34 PM

All,

Just to clarify our position regarding windows vista and PROIV. First some facts.

1. MS only support visual studio 2005 (with SP1 and another Vista SP) as their chosen development environment on Vista. MS have stated this one one of the Technology VP blogs.

2. PROIV 5.x and 6.0 are built using VS.NET 2003

3. VS.NET 2003 will load on Vista but wont debug

For PROIV to support Vista we need to migrate our C/C++ code from VS.NET 2003 to VS 2005; whilst the kernel is reasonably straight forward; the client is a bigger task due to changes in the MFC libraries we use. Given the changes required to accomodate the move we have decided to do this as part of the forthcomming 6.1 release. Here we will support Vista for use with the version 6 client; it is also our intention (famous last words i know!) to make the v6 client backwards compatible with the V5 menuing model. This will then only require one installation of the client on a workstation.

regards

james

#4 mdexter

mdexter

    Advanced

  • Members
  • PipPipPip
  • 70 posts
  • Gender:Male

Posted 09 February 2007 - 09:49 PM

We have at least two customers who report to us that they are successfully using our PRO-IV 5.5-based app with Vista. We are not officially supporting it, since PRO-IV is not. However, it may be that it works ok with some tweaking. Mark Dexter

#5 Josef Derflinger

Josef Derflinger

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 11 July 2007 - 05:50 AM

I just got a new desktop, thought I might as well get vista. Now I find out the gui 5.5 does not work, and it is because of the gui development that I got the new machine in the first place. Now what?
Any work-around (compatibility xp sp2 does not do anything).

Edited by Josef Derflinger, 11 July 2007 - 05:53 AM.


#6 zaytsevi

zaytsevi

    Member

  • Members
  • PipPip
  • 15 posts

Posted 23 August 2007 - 10:22 PM

i have found that one client disabled the "prompt for admin approval" and had everything run as Administrator. He got the client to work properly that way.

you can find some useful informatio here:
http://www.howtogeek.../windows-vista/

Edited by zaytsevi, 23 August 2007 - 10:24 PM.




Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users