Jump to content


- - - - -

Upgrade problem


2 replies to this topic

#1 Guest_Dennis_*

Guest_Dennis_*
  • Guests

Posted 06 September 2006 - 09:14 AM

We’ve upgraded our ProIV from Version : 4.0000 5.2.6 Jan 18, 99 to version Version : 5.5000 4.1.1 Jan 26, 05. And we’re having weird problems. We have also BTW upgraded our Oracle from 734 to 9i.

1. Main problem is any external database would not allow any write (Change, Delete and Add) but only read only process.
2. Screens that were working fine before are now having fields being blanked out, some windows F4 are not working
3. Report and update functions is not processing correctly. It goes in the function Logic In but is not going through the Default Logic of the primary LU/LR.

#2 Rob_Stebbens

Rob_Stebbens

    Member

  • Members
  • PipPip
  • 30 posts
  • Gender:Male

Posted 06 September 2006 - 02:18 PM

We’ve upgraded our ProIV from Version : 4.0000 5.2.6 Jan 18, 99 to version Version : 5.5000 4.1.1 Jan 26, 05. And we’re having weird problems. We have also BTW upgraded our Oracle from 734 to 9i.

1. Main problem is any external database would not allow any write (Change, Delete and Add) but only read only process.
2. Screens that were working fine before are now having fields being blanked out, some windows F4 are not working
3. Report and update functions is not processing correctly. It goes in the function Logic In but is not going through the Default Logic of the primary LU/LR.

1. Sounds like you migrated the database but left it in read only mode.
2. I'm not surprised. There's always an element of re-working required.
3. as above.

#3 George Macken

George Macken

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Co. Wicklow, Ireland

Posted 06 September 2006 - 03:26 PM

Hi

We've done a very similar upgrade and we got no/few problems, upgrade went very smoothly (surprisingly), but we had referred to earlier posts on this forum in advance of the upgrade. We are using v5.5 & GUI & ORACLE 9 on (I think) Win2003. What O/S are you using.

1) as already mentioned I think you need an ORACLE DBA as its an ORACLE problem, or that the Pro-Iv Oracle user has not got the rights to update the tables.

2) I think there can be problem when trying to overlay fields with other fields, that is the same/different fields at same screen co-ordinates in a function. Use Refresh to re-display the field.

3) We had absolutely no problems with Updates/Reports (we've 100s updates and few reports), maybe once problem 1 sorted this problem will go away. Have your reports got sorts/selects, maybe your app is failing to create the temp files/tables needed to produce the data etc.,

Rgds

George



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users