Jump to content


Photo
- - - - -

Prevent Form Feed On Report


7 replies to this topic

#1 lawalton

lawalton

    Member

  • Members
  • PipPip
  • 29 posts
  • Gender:Female

Posted 26 July 2006 - 02:06 PM

Hello all,

I'm using v.5.5 Rev.3.1.2, GUI and greenscreen. The printer I am using for this report is an OKI Microline 320.

I am trying to suppress the form feed at the end of a report. It is a label print where the user has the option of printing one or more labels to the printer. I would like the print job to finish at the end of the last label without doing a form feed to the end of the page. The report has one LS. The page length is defined as "blank". I have suppressed page header, first line and first form feed. I have an EOF control break with no line skips. (I have tried the report with no control breaks, and this did not stop the form feed.) Does anyone have any ideas or suggestions?

Thanks,

Leigh Anne

#2 Chris Pepper

Chris Pepper

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 369 posts
  • Gender:Male
  • Location:United Kingdom

Posted 26 July 2006 - 02:41 PM

ProIV normally does a page-throw at the start of a document, not at the end of one (this can be suppressed by the $SPOOL option).

Are you sure that it is not the next running of a Report function that is causing the page-throw?

Alternately, it could be being put there by the spooler software that is driving the printer (assuming you have some).

#3 DARREN

DARREN

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 396 posts
  • Gender:Male
  • Location:Florida,USA

Posted 26 July 2006 - 03:16 PM

I encountered a simmilar issue several years ago. The solution for us was to print the PCL code (escape sequence) before the main report that changed the length of the print page. HP documents their PCL codes quite well, other vendors are not so forth comming. This may be the solution.

One other solution is to referene the printer by its physical device name e.g /dev/rmt/printerdevice (for UNIX) or \myprinterserver\myprinter (for windows). Ensure that you have set the spooler switches to be a physical device (or use the correct report type when using @RPTOPT).
Things should be made as simple as possible, but not simpler

#4 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 26 July 2006 - 05:20 PM

I'd suspect the same as Dr Pepper - that the trailing FF is not coming from ProIV at all.
If you output your report to a file and inspect the file, is there an FF at the end or not?

HTH.

#5 Joseph Bove

Joseph Bove

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 756 posts
  • Gender:Male
  • Location:Ramsey, United States

Posted 26 July 2006 - 05:31 PM

Leigh,

What OS are you on?

You may need to edit the print spooler script directly to take out form feeds on *NIX based systems.

hth,

Joseph

#6 Lewis Mccabe

Lewis Mccabe

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 455 posts
  • Gender:Male
  • Location:Sarasota, Florida

Posted 26 July 2006 - 06:45 PM

We ran into this very problem in Unix some time ago. We needed to modify our printer model script. We added a switch for turning off a trailing form feed. We then could set the switch in PRO-IV to turn off and on as necessary.

I have never seen PRO-IV append a print file with FF - it has always been the OS.

#7 Bob Filipiak

Bob Filipiak

    Expert

  • Members
  • PipPipPipPip
  • 133 posts
  • Gender:Male

Posted 27 July 2006 - 12:46 PM

lawalton,

I had EXACTLY the same problem when I was trying to get our PRO-IV based acctg system to correctly print on preprinted invoice forms. Both the form tossing at start of report, and stopping dead at the last line of the report were new tricks to me.

Lewis has one possible solution - check your model printer script, look for an "ECHO 14" being sent after the last file.

I lost a lot of hair trying to nail that one down. BTW, there are TWO incantations of the OKI 32x series - OKI emulation and IBM emulation. try to avoid any hard coding of control chars because if you replace one with the other, well . . . . . . . . . . . .

I used vvars to hold the start and end control sequences.

Bob Filipiak

#8 lawalton

lawalton

    Member

  • Members
  • PipPip
  • 29 posts
  • Gender:Female

Posted 27 July 2006 - 02:56 PM

Thanks for all your responses. I am on a Unix operating system, and I can see it is not a Pro-IV problem as there are no escape sequences or printer commands in my output if I view it in a text file. I'm sure I'll be able to sort this one out I with one or more of your suggestions...



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users