Jump to content


Photo
- - - - -

Function Lock in 5.5


2 replies to this topic

#1 Lukas D

Lukas D

    Newbie

  • Members
  • Pip
  • 4 posts
  • Gender:Male

Posted 05 May 2003 - 07:36 AM

:-" I have an update locked on a version 5.5 system i have running on Oracle 8.1i on a linux machine . I get the function locked message when attempting to enter the function in developer studio and when trying @modx . I have tried doing an fuser on all dev studio files and made sure there are no processes running on the linux machine and still no luck .

Please could anyone suggest something ?

Regards

Lukas Delport

#2 Rob Donovan

Rob Donovan

    rob@proivrc.com

  • Admin
  • 1,640 posts
  • Gender:Male
  • Location:Spain

Posted 05 May 2003 - 10:50 AM

Hi,

What file does it say is locked... What is the extact message you get?

Also, do you have a process called iscollect running in the background?

There is a utility called isview (ProIV util that comes with ProIV, along with isin,iskeys etc).
This utility lists all the ProISAM record locks / open files on the system.

If you run isview and save the output to a file and attach it to a post, I could see which files and what processes have files locked.

Rob D.

#3 mwlowcock

mwlowcock

    Member

  • Members
  • PipPip
  • 13 posts
  • Gender:Male
  • Location:Crewe, England

Posted 10 May 2003 - 08:30 PM

Have you been accessing the function in VIP. I had it locking functions if I didn't close VIP properly.

In the client there is a VIP menu with a close option on it. Also see if VIP thinks it is part of the current project and try to close it from there.



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users