Jump to content


Photo
- - - - -

c-isam problem


2 replies to this topic

#1 Rob Fantini

Rob Fantini

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 267 posts
  • Gender:Male
  • Location:Haverhill, United States

Posted 27 November 1999 - 09:31 PM

using SCO 5.0.5. proIV ver 4 release:532

I've some C-ISAM files with alternate indexes.
I use the alternate indexs to select records fast.

In some functions the alt index selects records to be deleted, then added using a different key. This worked fine from 1996 thru recent releases.
For some reason this does not work now.

The deletes are done, but the adds either don't happen or the keys get mangled.
Has anyone else seen this?

#2 James Lolley

James Lolley

    Member

  • Members
  • PipPip
  • 13 posts
  • Gender:Male
  • Location:Guelph, Canada

Posted 28 November 1999 - 04:21 PM

Rob: we do use C-ISAM with HP-UX, but we don't use alternate indexes...we build our own as required to maintain compatibility with Pro-ISAM. Sorry we can't help!

#3 Rob Fantini

Rob Fantini

    ProIV Guru

  • Members
  • PipPipPipPipPip
  • 267 posts
  • Gender:Male
  • Location:Haverhill, United States

Posted 29 November 1999 - 04:52 AM

Dan Shannon sent me a solution:

I've only seen this happen if you try to access the index itself in delete
mode or add mode - that can screw things up pretty badly. But if you have
the index in Lookup, and delete the record from the primary and then re-add
it to the primary I haven't seen a problem. You could try using an
alternate instead as a workaround, that may help!



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users